Why Isn’t My Google Voice Ringing?

This is what I was wondering earlier today when I noticed that calls were not ringing in and when I went to make a call I was greeted with an error message from the OBI100. After looking into it and logging into the OBI portal they wanted me to pay $10 for support to update the device to the latest firmware and setup my Google Voice again. I decided to look online and found that they had the firmware available publically and if you follow the steps below your service will start working again.

I think it is crazy that they want to charge you $10 for “priority support” just to do something that they offer for free on their site and support forums. I am willing to bet that some unsuspecting people have paid the fee and not realized that it can be fixed easily on their own.

This was broken because Google forced everyone to switch to OAUTH 2.0 and this broke the old Google Voice system that the older firmware used.


Step 1

Download this firmware for the OBI100/OBI110 and install it. If you do not know how to install the firmware please see below for instructions.

 

Then Reboot.


Step 2

In the OBITalk Portal, delete the device and set it up again as a new device.

Run through the Google Voice setup again and it will start working again!

NOTE – It may take 4-5 minutes for the OBI to get the new settings but just be patient.


How to Update the Firmware

If you don’t know how to install the firmware:

Dial * * * 1

It will give  you the IP Address:  192.168.XXX.XXX   (example 192.168.1.27 )

In your browser, enter the IP Address as the URL.

User Name: admin
password: admin

 

On the left side, navigate to SYSTEM MANAGEMENT

Click DEVICE UPDATE

At the top where it says “Firmware Update – Select file to update firmware [BROWSE] ….”

Click BROWSE and add the file.  Then click UPLOAD

OBI100/110 Update Screen
OBI100/110 Update Screen

Once it reboots its done.

Go back to Step 2 to continue.

Thanks for reading and enjoy this fix!