Basic Sonicwall SonicPoint Ni/Ne/NDR Troubleshooting

At my job I get to work with all sorts of wireless technologies. We have been using Sonicwall SonicPoint access points at a lot of our clients and for the most part they are very solid. However we have had some issues with them dropping traffic and/or locking up. If you are having the same/similar issues try a few things.

  1. Check under SonicPoint > RF Analysis and see what your “RF Score” for the AP that is having issues is. If it is less than 6 look and see what channel is the least crowded and make note of it.
  2. Under SonicPoint > SonicPoints go to the edit properties for the AP you are troubleshooting. Go to the Radio (0 is 5ghz on NDR and 1 is 2.4ghz on NDR, Ne & Ni only have 1 radio that operates on either band).
  3. Change the band to “Standard – 20MHz Channel” and then select the channel that had the least interference in Step 1.
  4. Disable (uncheck) “Enable Short Guard Interval” and “Enable Aggregation”. Apply the settings. NOTE – If you have iPads and iPhones it is ALWAYS recommended to disable Aggregation as they do not adhere properly to the 802.11n standard and this will cause issues.

After you have made these changes you can also try adjusting the power from Full to Half, this has helped in the past with unruly APs probably due to heat. If you are still having issues with dropped traffic or disconnects then change the “Fragmentation Threshold” and “RTS Threshold” from 2346 to 2300 and keep going to a lower number until you find one that helps stabilize the connection. Be sure to set BOTH of them to the SAME number.

I hope this helps someone out. Send me any input and/or suggestions if you have them.

SonicPoint N Series

Fixing Sonicwall SSO Agent/Directory Connector Connection Issue

I have been having repeat issues with the Sonicwall SSO Agent/Directory Connector showing offline (red) in the SSO Agent settings in the Sonicwall. After trying multiple fixes I finally found one that works. The issue is caused by the default configuration that the installer creates having issues and these steps below will re-write that with the correct information and allow the service to work properly.

Start by loading the Directory Connector Configurator application and then change the Shared Key using the auto-generated key. Copy the key and paste it into the Sonicwall SSO Agent configuration and apply the new settings in the Sonicwall and the Directory Connector Configurator. Once this is done follow the steps below in the screenshots. Once these steps are complete it should show as online (green) in the SSO Agent settings. If it does not please let me know and I’ll see if I can find a fix. Also if you have Sonicwall support I would suggest giving them a ring and see what they say.

Wansview Firmware Updates/Hacks

Wansview NCB-541W
Wansview NCB-541W

So I recently purchased 2 Wansview NCB-541W IP cameras from Amazon. I knew they were going to require some tinkering but I was ok with that and welcomed the challenge. I am going to post a more detailed post but for now I wanted to share a few links for other users to update their firmware and also a FTP site that has their firmware on it.

I am not sure who owns or maintains this but there are tons of firmware and utilities on here that could prove to be useful. I am downloading the whole WansView folder right now and I will sort it out and post the files I found later.

FTP Site: everbest.ftpserver.biz/Share/Wansview

For the adventurous I flashed the Foscam FI8918W firmware and webUI on my Wansview cameras after I noticed that the firmware versions were very similar (21.37.2.x for WansView and 11.37.2.x for Foscam). The webUI firmware was completely different but worked. Here is the firmware for the FI8918W for firmware beginning in 21.37.2.x (Wansview) or 11.37.2.x (Foscam): Download

I would recommend the IP Cam utility for updating the firmware. You can download it here.

Foscam did send me links for another, older, firmware but I have not used those so I cannot vouch for its compatibility. Either way this is an “at your own risk” “ymmv” situation and I cannot be held liable if this bricks your cam. It worked on my 2 though.

Stay tuned for more details on this setup (DVR software, other tweaks, etc).